Akamai Status

Updated
Edge Delivery Issues
Incident Report for Akamai
Resolved
We have identified an issue with Edge delivery in the US East where customers might have observed performance degradation or availability issues for traffic going through the affected datacenters. The issue appears to have started around 00:45 UTC on March 19, 2024. We have implemented a fix and can confirm that the issue is now resolved as of 00:55 UTC on March 19, 2024 and the service has resumed normal operations. Customers and partners can view additional details about the incident, by logging in to: https://community.akamai.com/customers/s/feed/0D54R0000AailHbSQI or reaching out to Akamai Support.
We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Mar 19, 2024 - 00:45 UTC