Akamai Status

Updated
Certificate Provisioning Service Issues
Incident Report for Akamai
Resolved
We can confirm that the issue is now resolved as of 18:29 UTC on March 28, 2024 and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS or reaching out to Akamai Support.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Mar 28, 2024 - 18:58 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide the next update as we make progress.
Posted Mar 28, 2024 - 15:10 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide the next update as we make progress.
Posted Mar 27, 2024 - 08:55 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 22:32 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 19:30 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 16:39 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 13:42 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 10:49 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 08:07 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 04:10 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 26, 2024 - 01:03 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 25, 2024 - 22:00 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 25, 2024 - 19:01 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 25, 2024 - 16:11 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update on Monday March 25th or as additional information arrives during the weekend..
Posted Mar 22, 2024 - 22:51 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 20:10 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 17:16 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 14:24 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 07:58 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 04:17 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 22, 2024 - 01:14 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 21, 2024 - 21:05 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 21, 2024 - 19:31 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 180 minutes.
Posted Mar 21, 2024 - 16:53 UTC
Update
We are continuing to investigate this issue. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS. We will provide an update within the next 60 minutes.
Posted Mar 21, 2024 - 15:58 UTC
Investigating
We are investigating an emerging issue with Certificate Provisioning Service (CPS) related to significant slowness while accesing CPS UI. We are actively investigating the issue and will provide another update within the next 30 minutes.

If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community (https://community.akamai.com/customers/s/feed/0D54R0000AbKwuLSQS), or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Mar 21, 2024 - 15:31 UTC
This incident affected: Configuration (TLS Provisioning).