Akamai Status

Updated
Edge Delivery Performance Degradation in US
Incident Report for Akamai
Resolved
We can confirm that the issue is now resolved as of 21:30 UTC on March 20, 2024, and the service has resumed normal operation. Customers and partners can view additional details about the incident by logging in to: https://community.akamai.com/customers/s/feed/0D54R0000AbB5uJSQS or reaching out to Akamai Support.

We apologize for the impact and thank you for your patience and continued support. We are committed to making continuous improvements to make our systems better and prevent a recurrence of this issue.
Posted Mar 21, 2024 - 16:39 UTC
Monitoring
We have rolled back a release which we believe may have caused this issue as of 21:30 UTC on March 20, 2024; based on current observations, the service is resuming normal operations. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D54R0000AbB5uJSQS. We will continue to monitor to ensure that the impact has been fully mitigated.
Posted Mar 20, 2024 - 22:37 UTC
Identified
We have identified an issue with HTTP and HTTPs network traffic in the US related to performance degradation. The issue appears to have started around 19:30 UTC on March 19, 2024. We are currently working on applying a fix and will provide an update once it is deployed. The completion of this effort is targeted to be in approximately 2 hours.
If you have questions or are experiencing an impact due to this issue, please use the Support Center on Akamai Community, or Akamai Control Center, to contact Akamai Technical Support. Contact information is available at https://www.akamai.com/us/en/support/.
Posted Mar 20, 2024 - 20:12 UTC
This incident affected: Content Delivery (Edge Delivery).